Hi Namhyung, On Fri, 2018-11-23 at 16:01 +0900, Namhyung Kim wrote: > On Wed, Nov 14, 2018 at 02:18:02PM -0600, Tom Zanussi wrote: > > From: Tom Zanussi <tom.zanussi@xxxxxxxxxxxxxxx> > > > > [snip] > > - > > - update_max_vars(hist_data, elt, rbe, rec); > > + if (update_track_val(hist_data, elt, data, var_ref_vals)) > > + update_save_vars(hist_data, elt, rbe, rec); > > ... and then it should look like: > > if (check_track_val()) { > save_track_val(); > update_save_vars(); > } > > I also think update_save_vars() also needs to be renamed something > like save_track_vars() or save_trace_data(). > Yes, this is much nicer - I've made these changes and more for v8. Thanks for the input. Tom