On Tue, Oct 20, 2015 at 05:40:36PM +0200, Paolo Bonzini wrote: > > > On 20/10/2015 16:00, Peter Zijlstra wrote: > >> > - prepare_to_wait(&vcpu->wq, &wait, TASK_INTERRUPTIBLE); > >> > + prepare_to_swait(&vcpu->wq, &wait, TASK_INTERRUPTIBLE); > >> > > >> > if (kvm_vcpu_check_block(vcpu) < 0) > >> > break; > >> > @@ -2028,7 +2027,7 @@ void kvm_vcpu_block(struct kvm_vcpu *vcpu) > >> > schedule(); > >> > } > >> > > >> > - finish_wait(&vcpu->wq, &wait); > >> > + finish_swait(&vcpu->wq, &wait); > >> > cur = ktime_get(); > >> > > >> > out: > > Should we not take this opportunity to get rid of these open-coded wait > > loops? > > I find them way more readable than a 6-argument __wait_event... I could introduce wait_event_idle_cmd() and be at 3 if you think that helps. #define __wait_event_idle_cmd(wq, cond, cmd) \ ___wait_event(wq, cond, TASK_IDLE, 0, 0, cmd) etc.. Its that awkward waited variable that makes it hard to use the 'regular' 2 parameter thing. Although you could of course do horrible things like: __wait_event_idle(vcpu->wq, ({ bool done = kvm_cpu_check_block(vcpu) < 0; if (!done) waited = true; done; })); -- To unsubscribe from this list: send the line "unsubscribe linux-rt-users" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html