On Wed 07-05-14 16:27:10, Qiang Huang wrote: > It is only used in __mem_cgroup_begin_update_page_stat(), the > name is confusing and 2 routines for one thing also confuse people, > so fold this function seems more clear. Yes, the name was everything but self-explanatory. The patch looks good to me. One nit below. > Signed-off-by: Qiang Huang <h.huangqiang@xxxxxxxxxx> Acked-by: Michal Hocko <mhocko@xxxxxxx> > --- > mm/memcontrol.c | 25 +++++++------------------ > 1 file changed, 7 insertions(+), 18 deletions(-) > > diff --git a/mm/memcontrol.c b/mm/memcontrol.c > index 4f97662..5804d71 100644 > --- a/mm/memcontrol.c > +++ b/mm/memcontrol.c > @@ -1568,23 +1568,12 @@ static void mem_cgroup_end_move(struct mem_cgroup *memcg) > } > > /* > - * 2 routines for checking "mem" is under move_account() or not. > + * A routine for checking "mem" is under move_account() or not. > * > - * mem_cgroup_stolen() - checking whether a cgroup is mc.from or not. This > - * is used for avoiding races in accounting. If true, > - * pc->mem_cgroup may be overwritten. > - * > - * mem_cgroup_under_move() - checking a cgroup is mc.from or mc.to or > - * under hierarchy of moving cgroups. This is for > - * waiting at hith-memory prressure caused by "move". > + * Checking a cgroup is mc.from or mc.to or under hierarchy of > + * moving cgroups. > This is for waiting at hith-memory pressure s/hith/high/ but I guess that part can go away [...] -- Michal Hocko SUSE Labs -- To unsubscribe from this list: send the line "unsubscribe linux-rt-users" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html