-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 On 22/12/09 22:02, John Kacur wrote: > > > On Tue, 22 Dec 2009, David Sommerseth wrote: > >> Also renamed --refresh_on_max to --refresh-on-max >> >> Signed-off-by: David Sommerseth <davids@xxxxxxxxxx> >> --- >> src/cyclictest/cyclictest.c | 3 ++- >> 1 files changed, 2 insertions(+), 1 deletions(-) >> >> diff --git a/src/cyclictest/cyclictest.c b/src/cyclictest/cyclictest.c >> index 223f343..7979a77 100644 >> --- a/src/cyclictest/cyclictest.c >> +++ b/src/cyclictest/cyclictest.c >> @@ -788,6 +788,7 @@ static void display_help(int error) >> "-I --irqsoff Irqsoff tracing (used with -b)\n" >> "-l LOOPS --loops=LOOPS number of loops: default=0(endless)\n" >> "-m --mlockall lock current and future memory allocations\n" >> + "-M --refresh-on-max delay updating the screen until a new max latency is hit\n" >> "-n --nanosleep use clock_nanosleep\n" >> "-N --nsecs print results in ns instead of us (default us)\n" >> "-o RED --oscope=RED oscilloscope mode, reduce verbose output by RED\n" >> @@ -910,7 +911,7 @@ static void process_options (int argc, char *argv[]) >> {"irqsoff", no_argument, NULL, 'I'}, >> {"loops", required_argument, NULL, 'l'}, >> {"mlockall", no_argument, NULL, 'm' }, >> - {"refresh_on_max", no_argument, NULL, 'M' }, >> + {"refresh-on-max", no_argument, NULL, 'M' }, >> {"nanosleep", no_argument, NULL, 'n'}, >> {"nsecs", no_argument, NULL, 'N'}, >> {"oscope", required_argument, NULL, 'o'}, >> -- >> 1.6.2.5 >> >> > Hmnn, I'm not sure that I want to apply this one. > What is the motifivation for changing the name to refresh-on-max? > Right now refresh_on_max matches the global variable. The motivation is only to be consistent with the argument handling in the whole rt-tests suite. The rt-migrate-test uses dash instead of underscore (--run-time, --sleep-time). And considering that this feature is rather new (introduced in commit fc96b72126e79), I just thought it would be better to change this as soon as possible, before it is implemented in too many scripts. However, this is more a cosmetic change than a feature. I won't climb the barricades fighting for this patch ;-) It's only done to simplify things for users, not needing to remember which arguments uses underscore and which uses dash. David S. -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.9 (GNU/Linux) Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org/ iEYEARECAAYFAksx3l8ACgkQIIWEatLf4Hd/QgCeMFG60Jk+92eilUicDhDPXhhL erkAnjkLH5s9Cd6jDBBH0IY6qS9Zmu69 =xZgN -----END PGP SIGNATURE----- -- To unsubscribe from this list: send the line "unsubscribe linux-rt-users" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html