On Wed, 2007-10-17 at 11:10 -0400, Steven Rostedt wrote: > > > > > > #define read_seqbegin_irqsave(lock, flags) \ > > > -do { \ > > > +({ \ > > > flags = PICK_SEQ_OP_RET(__read_seqbegin_irqsave_raw, \ > > > __read_seqbegin_irqsave, lock); \ > > > -} while (0) > > > + read_seqbegin(lock); \ > > > +}) > > Yes, definitely the raw and unraw functions should be called > local_irqsave_raw or something else that makes this obvious to what it > is doing. Hmm.. I'm not sure what else to name them .. Since it's in the seqlock.h I don't think it should be called anything "local_irq*" .. It could be seq_irqsave_{raw} . Daniel - To unsubscribe from this list: send the line "unsubscribe linux-rt-users" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html