Hi Thomas. On Fri, Mar 06, 2020 at 04:18:52PM +0100, Thomas Zimmermann wrote: > Hi Laurent > > Am 06.03.20 um 15:22 schrieb Laurent Pinchart: > > Hi Thomas, > > > > Thank you for the patch. > > > > On Thu, Mar 05, 2020 at 04:59:28PM +0100, Thomas Zimmermann wrote: > >> A call to drm_simple_encoder_init() initializes an encoder without > >> further functionality. It only provides the destroy callback to > >> cleanup the encoder's state. Only few drivers implement more > >> sophisticated encoders than that. Most drivers implement such a > >> simple encoder and can use drm_simple_encoder_init() instead. > >> > >> The patchset converts drivers where the encoder's instance is > >> embedded in a larger data structure. The driver releases the > >> memory during cleanup. Each patch replaces drm_encoder_init() with > >> drm_simple_encoder_init() and removes the (now unused) driver's > >> encoder functions. > >> > >> While the patchset is fairly large, the indiviual patches are self- > >> contained and can be merged independently from each other. The > >> simple-encoder functionality is currently in drm-misc-next, where > >> these patches could go as well. > > > > I've reviewed the whole series, including verifying that the few > > instances of struct drm_encoder_funcs that were not declared const were > > not modified somewhere to add more function pointers. > > > > Reviewed-by: Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> > > Thanks for the detailed review. > > > > > for all the patches. > > > > However, I'd like to note that drm_simple_encoder_init() is a bit of a > > misnommer here. Several of the encoders in those drivers to implement > > additional functionality. They just expose them through > > drm_encoder_helper_funcs, not drm_encoder_funcs. > > True. It's called 'simple encoder' for the lack of a better name. It's > part of the simple KMS helpers, so the name's at least consistent. OTOH > I always find drm_simple_display_pipe a bad name. > > We can still rename the simple-encoder function without much effort. I'm > open for suggestions. IMO this does not belong in drm_simple_kms - but in drm_encoder. This only occurs to me after looking a bit more on the patches, you would have loved to get this feedback earlier. Most users do not need their owm drm_encoder_funcs definition, and would be happy with the default as provided by drm_simple_* As the cleanup is handled automatically when the drm device is teared down (in mode_config_rest()) I considered if we could here use the drmm_ namespace - but that felt wrong. My proposal is the following: - Move the implementation to drm_encoder.c - Name it drm_encoder_init_nofuncs() The patches posted in this thread would be a little simpler as they would loose the added include file. And the three drivers using the current infrastructure would need a small update. I you decide to keep the current approach where the functions are in drm_simple_* then the full series is: Acked-by: Sam Ravnborg <sam@xxxxxxxxxxxx> But I think moving it to drm_encoder.c would be the approach that would make it simpler to understand/follow. So that get my (biased) vote. Sam _______________________________________________ Linux-rockchip mailing list Linux-rockchip@xxxxxxxxxxxxxxxxxxx http://lists.infradead.org/mailman/listinfo/linux-rockchip