Hi Daniel: On 2016?05?31? 07:16, Daniel Lezcano wrote: > On 05/25/2016 11:50 AM, Caesar Wang wrote: >> From: Huang Tao <huangtao at rock-chips.com> >> >> The rockchip timer is broadcast timer. Add CLOCK_EVT_FEAT_DYNIRQ >> flag and set cpumask to all cpu to save power by avoid unnecessary >> wakeups and IPIs. >> >> Signed-off-by: Huang Tao <huangtao at rock-chips.com> >> Cc: Daniel Lezcano <daniel.lezcano at linaro.org> >> Cc: Thomas Gleixner <tglx at linutronix.de> >> Cc: Heiko Stuebner <heiko at sntech.de> >> Tested-by: Jianqun Xu <jay.xu at rock-chips.com> >> Signed-off-by: Caesar Wang <wxt at rock-chips.com> >> --- >> >> drivers/clocksource/rockchip_timer.c | 5 +++-- >> 1 file changed, 3 insertions(+), 2 deletions(-) >> >> diff --git a/drivers/clocksource/rockchip_timer.c b/drivers/clocksource/rockchip_timer.c >> index b93fed6..f3dfb1a 100644 >> --- a/drivers/clocksource/rockchip_timer.c >> +++ b/drivers/clocksource/rockchip_timer.c >> @@ -150,12 +150,13 @@ static void __init rk_timer_init(struct device_node *np) >> } >> >> ce->name = TIMER_NAME; >> - ce->features = CLOCK_EVT_FEAT_PERIODIC | CLOCK_EVT_FEAT_ONESHOT; >> + ce->features = CLOCK_EVT_FEAT_PERIODIC | CLOCK_EVT_FEAT_ONESHOT | >> + CLOCK_EVT_FEAT_DYNIRQ; >> ce->set_next_event = rk_timer_set_next_event; >> ce->set_state_shutdown = rk_timer_shutdown; >> ce->set_state_periodic = rk_timer_set_periodic; >> ce->irq = irq; >> - ce->cpumask = cpumask_of(0); >> + ce->cpumask = cpu_all_mask; > > s/cpu_all_mask/cpu_possible_mask/ Okay for me. It seems drivers in drivers/clocksource are very confusing about use cpu_all_mask or cpu_possible_mask. For example arm_arch_timer.c use cpu_all_mask, while mtk_timer.c use cpu_possible_mask. I think all just work. Thanks, Huang, Tao