> +/** > + * get_parity8 - get the parity of an u8 value I know it's prototypical bikeshedding, but what's with the "get_" prefix? Certainly the purpose of any pure function is to "get" the result of some computation. We don't have "get_strlen()". Please either just "parity8", or if you want to emphasize that this belongs in the bit-munging family, "bit_parity8". > + * @value: the value to be examined > + * > + * Determine the parity of the u8 argument. > + * > + * Returns: > + * 0 for even parity, 1 for odd parity > + * > + * Note: This function informs you about the current parity. Example to bail > + * out when parity is odd: > + * > + * if (get_parity8(val) == 1) > + * return -EBADMSG; > + * > + * If you need to calculate a parity bit, you need to draw the conclusion from > + * this result yourself. Example to enforce odd parity, parity bit is bit 7: > + * > + * if (get_parity8(val) == 0) > + * val |= BIT(7); Shouldn't that be ^= in general? Of course in some particular application one may have constructed the value in the lower 7 bits and "know" that bit 7 is currently clear. Rasmus