On 4/24/24 10:45 AM, Geert Uytterhoeven wrote: > As interrupts are now requested from ravb_probe(), before calling > register_netdev(), ndev->name still contains the template "eth%d", > leading to funny names in /proc/interrupts. E.g. on R-Car E3: > > 89: 0 0 GICv2 93 Level eth%d:ch22:multi > 90: 0 3 GICv2 95 Level eth%d:ch24:emac > 91: 0 23484 GICv2 71 Level eth%d:ch0:rx_be > 92: 0 0 GICv2 72 Level eth%d:ch1:rx_nc > 93: 0 13735 GICv2 89 Level eth%d:ch18:tx_be > 94: 0 0 GICv2 90 Level eth%d:ch19:tx_nc > > Worse, on platforms with multiple RAVB instances (e.g. R-Car V4H), all > interrupts have similar names. > > Fix this by using the device name instead, like is done in several other > drivers: > > 89: 0 0 GICv2 93 Level e6800000.ethernet:ch22:multi > 90: 0 1 GICv2 95 Level e6800000.ethernet:ch24:emac > 91: 0 28578 GICv2 71 Level e6800000.ethernet:ch0:rx_be > 92: 0 0 GICv2 72 Level e6800000.ethernet:ch1:rx_nc > 93: 0 14044 GICv2 89 Level e6800000.ethernet:ch18:tx_be > 94: 0 0 GICv2 90 Level e6800000.ethernet:ch19:tx_nc Ugh! Sorry about missing this one... > Rename the local variable dev_name, as it shadows the dev_name() > function, and pre-initialize it, to simplify the code. Why not call it just name instead? > Fixes: 32f012b8c01ca9fd ("net: ravb: Move getting/requesting IRQs in the probe() method") > Signed-off-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx> Reviewed-by: Sergey Shtylyov <s.shtylyov@xxxxxx> [...] MBR, Sergey