On 4/11/24 2:44 PM, Paul Barker wrote: > The RX byte accounting for jumbo packets was changed to fix a potential > use-after-free bug. However, that fix used the wrong variable and so > only accounted for the number of bytes in the final descriptor, not the > number of bytes in the whole packet. > > To fix this, we can simply update our stats with the correct number of > bytes before calling napi_gro_receive(). > > Also rename pkt_len to desc_len in ravb_rx_gbeth() to avoid any future > confusion. The variable name pkt_len is correct in ravb_rx_rcar() as > that function does not handle packets spanning multiple descriptors. > > Fixes: 5a5a3e564de6 ("ravb: Fix potential use-after-free in ravb_rx_gbeth()") > Signed-off-by: Paul Barker <paul.barker.ct@xxxxxxxxxxxxxx> Reviewed-by: Sergey Shtylyov <s.shtylyov@xxxxxx> [...] MBR, Sergey