On Sun, Feb 04, 2024 at 11:44:39PM +0000, Kuninori Morimoto wrote: > > Hi Rob > > > This is assuming there's just 1 port and 1 endpoint, but let's be > > specific as the bindings are (first endpoint on port 0): > > > > of_graph_get_endpoint_by_regs(client->dev.of_node, 0, -1); > > > > Note we could ask for endpoint 0 here, but the bindings generally allow > > for more than 1. > > > > I imagine most of the other cases here are the same. > > I will do it on new patch-set > > > > - for_each_endpoint_of_node(state->dev->of_node, ep_np) { > > > + for_each_device_endpoint_of_node(state->dev->of_node, ep_np) { > > > > I would skip the rename. > > It is needed to avoid confuse, because new function will add > another endpoint loop. > > see > https://lore.kernel.org/r/20240131100701.754a95ee@booty I've read the threads already and think you should skip the rename. Just put 'port' in the name of the new one. That and taking a port number param should be enough distinction. Rob