On Wed, Dec 13, 2023 at 10:55:46AM +0100, Paul Cercueil wrote: > Le lundi 11 décembre 2023 à 20:57 +0200, Andy Shevchenko a écrit : ... > > -#define INGENIC_PIN_GROUP(name, id, func) \ > > - INGENIC_PIN_GROUP_FUNCS(name, id, (void *)(func)) > > +#define INGENIC_PIN_GROUP(_name_, id, > > func) \ > > + { > > \ > > + .name = > > _name_, \ > > + .pins = > > id##_pins, \ > > + .num_pins = > > ARRAY_SIZE(id##_pins), \ > > + .data = (void > > *)func, \ > > + } > > This INGENIC_PIN_GROUP() macro doesn't need to be modified, does it? We can go either way. I prefer to go this way as it reduces level of indirections in the macros. It makes code easier to read and understand. But if you insist, I can drop that change in next version. -- With Best Regards, Andy Shevchenko