On Wed, Mar 08, 2023 at 11:48:17AM +0100, Geert Uytterhoeven wrote: > Use the existing of_fwnode_handle() helper instead of open-coding the > same operation. LGTM, Reviewed-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> > Signed-off-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx> > --- > To be queued in renesas-devel-for-v6.4. > > drivers/soc/renesas/rmobile-sysc.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/soc/renesas/rmobile-sysc.c b/drivers/soc/renesas/rmobile-sysc.c > index 204e6135180b919c..728ebac98e14a5cc 100644 > --- a/drivers/soc/renesas/rmobile-sysc.c > +++ b/drivers/soc/renesas/rmobile-sysc.c > @@ -343,7 +343,7 @@ static int __init rmobile_init_pm_domains(void) > break; > } > > - fwnode_dev_initialized(&np->fwnode, true); > + fwnode_dev_initialized(of_fwnode_handle(np), true); > } > > put_special_pds(); -- With Best Regards, Andy Shevchenko