Re: [PATCH] base: soc: Make soc_device_match() simpler and easier to read

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, Mar 1, 2022 at 12:10 PM Geert Uytterhoeven
<geert+renesas@xxxxxxxxx> wrote:
>
> The function soc_device_match() is difficult to read for various
> reasons:
>   - There are two loop conditions using different styles: "while (...)"
>     (which is BTW always true) vs. "if ... break",
>   - The are two return condition using different logic: "if ... return
>     foo" vs. "if ... else return bar".
>
> Make the code easier to read by:
>   1. Removing the always-true "!ret" loop condition, and dropping the
>      now unneeded pre-initialization of "ret",
>   2. Converting "if ... break" to a proper "while (...)" loop condition,
>   3. Inverting the logic of the second return condition.
>
> Signed-off-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx>
> ---

Reviewed-by: Arnd Bergmann <arnd@xxxxxxxx>



[Index of Archives]     [Linux Samsung SOC]     [Linux Wireless]     [Linux Kernel]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Samba]     [Device Mapper]

  Powered by Linux