Hi Biju, On Wed, Aug 18, 2021 at 9:08 PM Biju Das <biju.das.jz@xxxxxxxxxxxxxx> wrote: > R-Car Gen2 needs a 4byte aligned address for the transmission buffer, > whereas R-Car Gen3 doesn't have any such restriction. > > Add aligned_tx to struct ravb_hw_info to select the driver to choose > between aligned and unaligned tx buffers. > > Signed-off-by: Biju Das <biju.das.jz@xxxxxxxxxxxxxx> > Reviewed-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@xxxxxxxxxxxxxx> Thanks for your patch, which is now commit 68ca3c923213b908 ("ravb: Add aligned_tx to struct ravb_hw_info") in net-next. > --- a/drivers/net/ethernet/renesas/ravb.h > +++ b/drivers/net/ethernet/renesas/ravb.h > @@ -990,6 +990,7 @@ enum ravb_chip_id { > > struct ravb_hw_info { > enum ravb_chip_id chip_id; > + unsigned aligned_tx: 1; > }; > > struct ravb_private { > diff --git a/drivers/net/ethernet/renesas/ravb_main.c b/drivers/net/ethernet/renesas/ravb_main.c > index b6554e5e13af..dbccf2cd89b2 100644 > --- a/drivers/net/ethernet/renesas/ravb_main.c > +++ b/drivers/net/ethernet/renesas/ravb_main.c > @@ -1930,6 +1930,7 @@ static const struct ravb_hw_info ravb_gen3_hw_info = { > > static const struct ravb_hw_info ravb_gen2_hw_info = { > .chip_id = RCAR_GEN2, > + .aligned_tx = 1, > }; > > static const struct of_device_id ravb_match_table[] = { > @@ -2140,7 +2141,7 @@ static int ravb_probe(struct platform_device *pdev) > ndev->max_mtu = 2048 - (ETH_HLEN + VLAN_HLEN + ETH_FCS_LEN); > ndev->min_mtu = ETH_MIN_MTU; > > - priv->num_tx_desc = info->chip_id == RCAR_GEN2 ? > + priv->num_tx_desc = info->aligned_tx ? > NUM_TX_DESC_GEN2 : NUM_TX_DESC_GEN3; At first look, this change does not seem to match the patch description. Upon a deeper look, it is correct, as num_tx_desc is also used to control alignment. But now NUM_TX_DESC_GEN[23] no longer match their use. Perhaps they should be renamed, or replaced by hardcoded values, with a comment? /* * FIXME: Explain the relationship between alignment and number of buffers */ priv->num_tx_desc = info->aligned_tx ? 2 : 1; > > /* Set function */ Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds