Re: [PATCH 01/11] clk: renesas: cpg-mssr: add support for ignore-unused clocks

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



> +	for (i = 0; i < info->num_used_mod_clks; i++)

I think the naming of 'used' is a bit unfortunate because the flag is
'unused'. The most readable would be 'ignore_unused_mod_clks' probably?
But this is kinda long. 'kept_mod_clks'? I really don't want to
bikeshed over this, but maybe we can lower the potential confusion here?

> +		if (id == info->used_mod_clks[i]) {
> +			dev_dbg(dev, "MSTP %s setting CLK_IGNORE_UNUSED\n",
> +				mod->name);

Can we remove this? We can check this easily in debugfs/clk. Yes, I know
CLK_CRITICAL has it, too. Maybe we can remove it there, too. Or just
move it to the final dev_dbg before the function leaves?

Attachment: signature.asc
Description: PGP signature


[Index of Archives]     [Linux Samsung SOC]     [Linux Wireless]     [Linux Kernel]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Samba]     [Device Mapper]

  Powered by Linux