Re: [PATCH 6/7] clocksource/drivers/sh_cmt: r8a7740 and sh73a0 SoC-specific match

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Jul 18, 2019 at 08:45:24PM +0900, Magnus Damm wrote:
> From: Magnus Damm <damm+renesas@xxxxxxxxxxxxx>
> 
> Add SoC-specific matching for CMT1 on r8a7740 and sh73a0.
> 
> This allows us to move away from the old DT bindings such as
>  - "renesas,cmt-48-sh73a0"
>  - "renesas,cmt-48-r8a7740"
>  - "renesas,cmt-48"
> in favour for the now commonly used format "renesas,<soc>-<device>"
> 
> Signed-off-by: Magnus Damm <damm+renesas@xxxxxxxxxxxxx>

Reviewed-by: Simon Horman <horms+renesas@xxxxxxxxxxxx>

> ---
> 
>  drivers/clocksource/sh_cmt.c |    8 ++++++++
>  1 file changed, 8 insertions(+)
> 
> --- 0001/drivers/clocksource/sh_cmt.c
> +++ work/drivers/clocksource/sh_cmt.c	2019-07-18 19:29:06.005414716 +0900
> @@ -928,6 +928,14 @@ static const struct of_device_id sh_cmt_
>  		.data = &sh_cmt_info[SH_CMT0_RCAR_GEN2]
>  	},
>  	{
> +		.compatible = "renesas,r8a7740-cmt1",
> +		.data = &sh_cmt_info[SH_CMT_48BIT]

Perhaps as a follow-up SH_CMT_48BIT could be renamed.

> +	},
> +	{
> +		.compatible = "renesas,sh73a0-cmt1",
> +		.data = &sh_cmt_info[SH_CMT_48BIT]
> +	},
> +	{
>  		.compatible = "renesas,rcar-gen2-cmt0",
>  		.data = &sh_cmt_info[SH_CMT0_RCAR_GEN2]
>  	},
> 



[Index of Archives]     [Linux Samsung SOC]     [Linux Wireless]     [Linux Kernel]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Samba]     [Device Mapper]

  Powered by Linux