Re: [PATCH] pinctrl: sh-pfc: r8a7795-es1: SSI_{WS/SCK}34 -> SSI_{WS/SCK}349

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Morimoto-san,

On Tue, May 16, 2017 at 10:01 AM, Kuninori Morimoto
<kuninori.morimoto.gx@xxxxxxxxxxx> wrote:
> From: Kuninori Morimoto <kuninori.morimoto.gx@xxxxxxxxxxx>
>
> R-Car Gen3 is using SSI_{WS/SCK}_349 instead of SSI_{WS/SCK}_34.
> But, current code is based on old datasheet which had typo.
> This patch fixes this typo.
>
> Signed-off-by: Kuninori Morimoto <kuninori.morimoto.gx@xxxxxxxxxxx>

You forgot to change the string in ssi_groups[], like below?

@@ -4509,7 +4509,7 @@ static const char * const ssi_groups[] = {
        "ssi2_ctrl_a",
        "ssi2_ctrl_b",
        "ssi3_data",
-       "ssi34_ctrl",
+       "ssi349_ctrl",
        "ssi4_data",
        "ssi4_ctrl",
        "ssi5_data",

Without that change, it won't work.

If you care about backwards compatibility (I thought you didn't?),
you have to keep the string "ssi34_ctrl", and add "ssi349_ctrl",
and add an open-coded entry in pinmux_group[]  like:

    {
        .name = "ssi34_ctrl",
        .pins = ssi349_pins,
        .mux = ssi349_mux,
        .nr_pins = ARRAY_SIZE(ssi349_pins),
    }

Or add a new macro SH_PFC_PIN_GROUP_ALIAS(n, alias).

The same comment applies to pfc-r8a7796.c.

If the intention was to change the string, I can make that change myself,
no need to resent.

Thanks!

Gr{oetje,eeting}s,

                        Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds



[Index of Archives]     [Linux Samsung SOC]     [Linux Wireless]     [Linux Kernel]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Samba]     [Device Mapper]

  Powered by Linux