On Tue, Dec 13, 2016 at 1:43 PM, Jacopo Mondi <jacopo@xxxxxxxxxx> wrote: > > diff --git a/arch/arm/boot/dts/r8a7791-koelsch.dts b/arch/arm/boot/dts/r8a7791-koelsch.dts > index 5405d33..1756b86 100644 > --- a/arch/arm/boot/dts/r8a7791-koelsch.dts > +++ b/arch/arm/boot/dts/r8a7791-koelsch.dts > + spi_gpio: spi-gpio@0 { > + compatible = "spi-gpio"; > + #address-cells = <1>; > + #size-cells = <0>; > + gpio-sck = <&gpio5 27 GPIO_ACTIVE_HIGH>; > + gpio-miso = <&gpio5 25 GPIO_ACTIVE_HIGH>; > + num-chipselects = <1>; > + cs-gpios = <&gpio5 26 GPIO_ACTIVE_LOW>; > + status = "okay"; > + > + adc0: max11100@0 { The node name should be a generic name, the label should be the specific name. I.e. "max11100: adc@0" > + compatible = "maxim,max11100"; > + reg = <0>; > + spi-max-frequency = <2500000>; > + vref-supply = <&vref_adc0>; Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds