Hi Lars Thank you for your feedback > > snd_soc_component_driver requests some struct xxx, and int num_xxx. > > To make initialize easy, this patch adds COMPONENT_FUNC() macro. > > > > Signed-off-by: Kuninori Morimoto <kuninori.morimoto.gx@xxxxxxxxxxx> > > --- > > include/sound/soc.h | 3 +++ > > 1 file changed, 3 insertions(+) > > > > diff --git a/include/sound/soc.h b/include/sound/soc.h > > index 6144882..41c21f9 100644 > > --- a/include/sound/soc.h > > +++ b/include/sound/soc.h > > @@ -795,6 +795,9 @@ struct snd_soc_component_driver { > > int probe_order; > > int remove_order; > > }; > > +#define COMPONENT_FUNC(name, func) \ > > + .name = func, \ > > + .num_##name = ARRAY_SIZE(func) > > I'd avoid like to a void this kind of macro. Sure it slightly reduces > boilerplate code, but it is difficult to parse for both humans as well as > machines. Makes the code much less intuitive to understand and also breaks > automated scripts. Thanks, and yes agree. Now, I'm creating many patches without above macro.