Re: [PATCH/RFC 1/4] mmc: renesas_sdhi: rename sh_mobile_sdhi as renesas_sdhi

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Jun 15, 2016 at 01:01:54PM +0900, Simon Horman wrote:
> The SDHI driver is applicable to a wider range of SoCs than SH-Mobile,
> Renesas seems to be a more appropriate name.
> 
> Signed-off-by: Simon Horman <horms+renesas@xxxxxxxxxxxx>

It feels strange to rename the file and leaving all the naming inside
the file still 'sh_mobile_*'. On the other hand, renaming all those,
too, is intrusive, so I wonder if we can't keep the filename "for
historic reasons"?

> ---
>  drivers/mmc/host/Kconfig                              | 4 ++--
>  drivers/mmc/host/Makefile                             | 2 +-
>  drivers/mmc/host/{sh_mobile_sdhi.c => renesas_sdhi.c} | 0
>  3 files changed, 3 insertions(+), 3 deletions(-)
>  rename drivers/mmc/host/{sh_mobile_sdhi.c => renesas_sdhi.c} (100%)
> 
> diff --git a/drivers/mmc/host/Kconfig b/drivers/mmc/host/Kconfig
> index 0aa484c10c0a..840b17150263 100644
> --- a/drivers/mmc/host/Kconfig
> +++ b/drivers/mmc/host/Kconfig
> @@ -560,13 +560,13 @@ config MMC_TMIO
>  	  T7L66XB and also HTC ASIC3
>  
>  config MMC_SDHI
> -	tristate "SH-Mobile SDHI SD/SDIO controller support"
> +	tristate "Renesas SDHI SD/SDIO controller support"
>  	depends on SUPERH || ARM || ARM64
>  	depends on SUPERH || ARCH_RENESAS || COMPILE_TEST
>  	select MMC_TMIO_CORE
>  	help
>  	  This provides support for the SDHI SD/SDIO controller found in
> -	  SuperH and ARM SH-Mobile SoCs
> +	  SuperH, and Renesas ARM and arm64 based SoCs.
>  
>  config MMC_CB710
>  	tristate "ENE CB710 MMC/SD Interface support"
> diff --git a/drivers/mmc/host/Makefile b/drivers/mmc/host/Makefile
> index af918d261ff9..206233218781 100644
> --- a/drivers/mmc/host/Makefile
> +++ b/drivers/mmc/host/Makefile
> @@ -38,7 +38,7 @@ obj-$(CONFIG_MMC_TMIO)		+= tmio_mmc.o
>  obj-$(CONFIG_MMC_TMIO_CORE)	+= tmio_mmc_core.o
>  tmio_mmc_core-y			:= tmio_mmc_pio.o
>  tmio_mmc_core-$(subst m,y,$(CONFIG_MMC_SDHI))	+= tmio_mmc_dma.o
> -obj-$(CONFIG_MMC_SDHI)		+= sh_mobile_sdhi.o
> +obj-$(CONFIG_MMC_SDHI)		+= renesas_sdhi.o
>  obj-$(CONFIG_MMC_CB710)		+= cb710-mmc.o
>  obj-$(CONFIG_MMC_VIA_SDMMC)	+= via-sdmmc.o
>  obj-$(CONFIG_SDH_BFIN)		+= bfin_sdh.o
> diff --git a/drivers/mmc/host/sh_mobile_sdhi.c b/drivers/mmc/host/renesas_sdhi.c
> similarity index 100%
> rename from drivers/mmc/host/sh_mobile_sdhi.c
> rename to drivers/mmc/host/renesas_sdhi.c
> -- 
> 2.1.4
> 

Attachment: signature.asc
Description: PGP signature


[Index of Archives]     [Linux Samsung SOC]     [Linux Wireless]     [Linux Kernel]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Samba]     [Device Mapper]

  Powered by Linux