On Mon, Jun 05, 2023 at 09:43:50PM +0200, Konrad Dybcio wrote: > On 5.06.2023 09:08, Stephan Gerhold wrote: > > Rather than having the RPM GLINK channels as the only child of a dummy > > top-level rpm-glink node, switch to representing the RPM as remoteproc > > like all the other remoteprocs (modem DSP, ...). > > > > This allows assigning additional subdevices to it like the MPM > > interrupt-controller or rpm-master-stats. > > > > Signed-off-by: Stephan Gerhold <stephan@xxxxxxxxxxx> > > --- > > arch/arm64/boot/dts/qcom/ipq6018.dtsi | 48 ++++++----- > > arch/arm64/boot/dts/qcom/ipq9574.dtsi | 28 ++++--- > > arch/arm64/boot/dts/qcom/msm8996.dtsi | 113 ++++++++++++------------- > > arch/arm64/boot/dts/qcom/msm8998.dtsi | 98 +++++++++++----------- > > arch/arm64/boot/dts/qcom/qcm2290.dtsi | 126 ++++++++++++++-------------- > > arch/arm64/boot/dts/qcom/qcs404.dtsi | 152 +++++++++++++++++----------------- > > arch/arm64/boot/dts/qcom/sdm630.dtsi | 132 +++++++++++++++-------------- > > arch/arm64/boot/dts/qcom/sm6115.dtsi | 128 ++++++++++++++-------------- > > arch/arm64/boot/dts/qcom/sm6125.dtsi | 140 ++++++++++++++++--------------- > > arch/arm64/boot/dts/qcom/sm6375.dtsi | 126 ++++++++++++++-------------- > > 10 files changed, 564 insertions(+), 527 deletions(-) > > > > diff --git a/arch/arm64/boot/dts/qcom/ipq6018.dtsi b/arch/arm64/boot/dts/qcom/ipq6018.dtsi > > index 7355f266742a..fff4a4014bd8 100644 > > --- a/arch/arm64/boot/dts/qcom/ipq6018.dtsi > > +++ b/arch/arm64/boot/dts/qcom/ipq6018.dtsi > > @@ -146,6 +146,32 @@ psci: psci { > > method = "smc"; > > }; > > > > + rpm: remoteproc-rpm { > Krzysztof, is this fine or should this be just `remoteproc {`? > What if you have multiple remoteprocs? I took this naming convention from sdm845.dtsi by the way: adsp_pas: remoteproc-adsp { compatible = "qcom,sdm845-adsp-pas"; cdsp_pas: remoteproc-cdsp { compatible = "qcom,sdm845-cdsp-pas"; Thanks, Stephan