On Thu 11 Mar 08:04 CST 2021, Arnaud Pouliquen wrote: > This series is the first step in the division of the series: > "Introduce a generic IOCTL interface for RPMsg channels management"[1] > > The main goal here is to enable the RPMsg char interface for > the virtio RPMsg backend. > > In addition some patches have been includes in order to document the > interface and rename the rpmsg_char_init function. > > It also includes Mathieu Poirier's comments made on [1] > > Patchsets that should be the next steps: > - Extract the control part of the char dev and create the rpmsg_ctrl.c > file > - Introduce the RPMSG_CREATE_DEV_IOCTL IOCTL to instantiate RPMsg devices > > > [1]: https://patchwork.kernel.org/project/linux-remoteproc/list/?series=435523 > Reviewed-by: Bjorn Andersson <bjorn.andersson@xxxxxxxxxx> Regards, Bjorn > Arnaud Pouliquen (6): > rpmsg: char: Rename rpmsg_char_init to rpmsg_chrdev_init > rpmsg: Move RPMSG_ADDR_ANY in user API > rpmsg: Add short description of the IOCTL defined in UAPI. > rpmsg: char: Use rpmsg_sendto to specify the message destination > address > rpmsg: virtio: Register the rpmsg_char device > rpmsg: char: Return an error if device already open > > drivers/rpmsg/qcom_glink_native.c | 16 ++++++++ > drivers/rpmsg/qcom_smd.c | 16 ++++++++ > drivers/rpmsg/rpmsg_char.c | 11 ++++-- > drivers/rpmsg/virtio_rpmsg_bus.c | 62 ++++++++++++++++++++++++++++--- > include/linux/rpmsg.h | 3 +- > include/uapi/linux/rpmsg.h | 13 ++++++- > 6 files changed, 108 insertions(+), 13 deletions(-) > > -- > 2.17.1 >