On Thu, 08 Sep 2016, loic pallardy wrote: > > > On 09/08/2016 10:48 AM, Lee Jones wrote: > > On Wed, 31 Aug 2016, Loic Pallardy wrote: > > > > > This patch proposes diverse updates to rproc_update_resource_table_entry > > > function: > > > - rename rproc_update_resource_table_entry to __update_rsc_tbl_entry to > > > have shorter function name. > > > - add RSC_VDEV support > > > - add force mode resource even if resource already fixed on firmware side. > > > > > > Signed-off-by: Loic Pallardy <loic.pallardy@xxxxxx> > > > --- > > > drivers/remoteproc/remoteproc_core.c | 27 ++++++++++++++++++++++----- > > > 1 file changed, 22 insertions(+), 5 deletions(-) > > > > > > diff --git a/drivers/remoteproc/remoteproc_core.c b/drivers/remoteproc/remoteproc_core.c > > > index 30e9c70..aff1a00 100644 > > > --- a/drivers/remoteproc/remoteproc_core.c > > > +++ b/drivers/remoteproc/remoteproc_core.c > > > @@ -1027,13 +1027,15 @@ static int __verify_rsc_tbl_entry(struct rproc *rproc, > > > return -EINVAL; > > > } > > > > > > -static int rproc_update_resource_table_entry(struct rproc *rproc, > > > +static int __update_rsc_tbl_entry(struct rproc *rproc, > > > > Unless the name is unruly, (which I don't think it is, you're still > > having to line wrap at the call site), I tend to go for clarity over > > brevity. > It was only to have reasonable line length. I can keept original name and > see impact on rest of the code. Reasonable line length is 80. This line was 65. -- Lee Jones Linaro STMicroelectronics Landing Team Lead Linaro.org │ Open source software for ARM SoCs Follow Linaro: Facebook | Twitter | Blog -- To unsubscribe from this list: send the line "unsubscribe linux-remoteproc" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html