> -----Original Message----- > From: Dan Williams <dan.j.williams@xxxxxxxxx> > Sent: Wednesday, October 7, 2020 11:32 PM > To: Leon Romanovsky <leon@xxxxxxxxxx> > Cc: Ertman, David M <david.m.ertman@xxxxxxxxx>; Parav Pandit > <parav@xxxxxxxxxx>; Pierre-Louis Bossart <pierre- > louis.bossart@xxxxxxxxxxxxxxx>; alsa-devel@xxxxxxxxxxxxxxxx; > parav@xxxxxxxxxxxx; tiwai@xxxxxxx; netdev@xxxxxxxxxxxxxxx; > ranjani.sridharan@xxxxxxxxxxxxxxx; fred.oh@xxxxxxxxxxxxxxx; linux- > rdma@xxxxxxxxxxxxxxx; dledford@xxxxxxxxxx; broonie@xxxxxxxxxx; Jason > Gunthorpe <jgg@xxxxxxxxxx>; gregkh@xxxxxxxxxxxxxxxxxxx; > kuba@xxxxxxxxxx; Saleem, Shiraz <shiraz.saleem@xxxxxxxxx>; > davem@xxxxxxxxxxxxx; Patil, Kiran <kiran.patil@xxxxxxxxx> > Subject: Re: [PATCH v2 1/6] Add ancillary bus support > > On Wed, Oct 7, 2020 at 10:21 PM Leon Romanovsky <leon@xxxxxxxxxx> > wrote: > > > > On Wed, Oct 07, 2020 at 08:46:45PM +0000, Ertman, David M wrote: > > > > -----Original Message----- > > > > From: Parav Pandit <parav@xxxxxxxxxx> > > > > Sent: Wednesday, October 7, 2020 1:17 PM > > > > To: Leon Romanovsky <leon@xxxxxxxxxx>; Ertman, David M > > > > <david.m.ertman@xxxxxxxxx> > > > > Cc: Pierre-Louis Bossart <pierre-louis.bossart@xxxxxxxxxxxxxxx>; alsa- > > > > devel@xxxxxxxxxxxxxxxx; parav@xxxxxxxxxxxx; tiwai@xxxxxxx; > > > > netdev@xxxxxxxxxxxxxxx; ranjani.sridharan@xxxxxxxxxxxxxxx; > > > > fred.oh@xxxxxxxxxxxxxxx; linux-rdma@xxxxxxxxxxxxxxx; > > > > dledford@xxxxxxxxxx; broonie@xxxxxxxxxx; Jason Gunthorpe > > > > <jgg@xxxxxxxxxx>; gregkh@xxxxxxxxxxxxxxxxxxx; kuba@xxxxxxxxxx; > Williams, > > > > Dan J <dan.j.williams@xxxxxxxxx>; Saleem, Shiraz > > > > <shiraz.saleem@xxxxxxxxx>; davem@xxxxxxxxxxxxx; Patil, Kiran > > > > <kiran.patil@xxxxxxxxx> > > > > Subject: RE: [PATCH v2 1/6] Add ancillary bus support > > > > > > > > > > > > > From: Leon Romanovsky <leon@xxxxxxxxxx> > > > > > Sent: Thursday, October 8, 2020 12:56 AM > > > > > > > > > > > > This API is partially obscures low level driver-core code and needs > > > > > > > to provide clear and proper abstractions without need to > remember > > > > > > > about put_device. There is already _add() interface why don't you > do > > > > > > > put_device() in it? > > > > > > > > > > > > > > > > > > > The pushback Pierre is referring to was during our mid-tier internal > > > > > > review. It was primarily a concern of Parav as I recall, so he can > speak to > > > > his > > > > > reasoning. > > > > > > > > > > > > What we originally had was a single API call > > > > > > (ancillary_device_register) that started with a call to > > > > > > device_initialize(), and every error path out of the function > performed a > > > > > put_device(). > > > > > > > > > > > > Is this the model you have in mind? > > > > > > > > > > I don't like this flow: > > > > > ancillary_device_initialize() > > > > > if (ancillary_ancillary_device_add()) { > > > > > put_device(....) > > > > > ancillary_device_unregister() > > > > Calling device_unregister() is incorrect, because add() wasn't > successful. > > > > Only put_device() or a wrapper ancillary_device_put() is necessary. > > > > > > > > > return err; > > > > > } > > > > > > > > > > And prefer this flow: > > > > > ancillary_device_initialize() > > > > > if (ancillary_device_add()) { > > > > > ancillary_device_unregister() > > > > This is incorrect and a clear deviation from the current core APIs that > adds the > > > > confusion. > > > > > > > > > return err; > > > > > } > > > > > > > > > > In this way, the ancillary users won't need to do non-intuitive > put_device(); > > > > > > > > Below is most simple, intuitive and matching with core APIs for name > and > > > > design pattern wise. > > > > init() > > > > { > > > > err = ancillary_device_initialize(); > > > > if (err) > > > > return ret; > > > > > > > > err = ancillary_device_add(); > > > > if (ret) > > > > goto err_unwind; > > > > > > > > err = some_foo(); > > > > if (err) > > > > goto err_foo; > > > > return 0; > > > > > > > > err_foo: > > > > ancillary_device_del(adev); > > > > err_unwind: > > > > ancillary_device_put(adev->dev); > > > > return err; > > > > } > > > > > > > > cleanup() > > > > { > > > > ancillary_device_de(adev); > > > > ancillary_device_put(adev); > > > > /* It is common to have a one wrapper for this as > > > > ancillary_device_unregister(). > > > > * This will match with core device_unregister() that has precise > > > > documentation. > > > > * but given fact that init() code need proper error unwinding, like > > > > above, > > > > * it make sense to have two APIs, and no need to export another > > > > symbol for unregister(). > > > > * This pattern is very easy to audit and code. > > > > */ > > > > } > > > > > > I like this flow +1 > > > > > > But ... since the init() function is performing both device_init and > > > device_add - it should probably be called ancillary_device_register, > > > and we are back to a single exported API for both register and > > > unregister. > > > > > > At that point, do we need wrappers on the primitives init, add, del, > > > and put? > > > > Let me summarize. > > 1. You are not providing driver/core API but simplification and obfuscation > > of basic primitives and structures. This is new layer. There is no room for > > a claim that we must to follow internal API. > > Yes, this a driver core api, Greg even questioned why it was in > drivers/bus instead of drivers/base which I think makes sense. Will move to drivers/base with next patch set. -DaveE