On 9/21/2020 7:53 PM, Jason Gunthorpe wrote:
On Mon, Sep 14, 2020 at 09:34:59AM +0300, Yishai Hadas wrote:
diff --git a/libibverbs/verbs.c b/libibverbs/verbs.c
index 9427aba..9dec4e6 100644
+++ b/libibverbs/verbs.c
@@ -216,10 +216,8 @@ LATEST_SYMVER_FUNC(ibv_query_port, 1_1, "IBVERBS_1.1",
sizeof(*port_attr));
}
-LATEST_SYMVER_FUNC(ibv_query_gid, 1_1, "IBVERBS_1.1",
- int,
- struct ibv_context *context, uint8_t port_num,
- int index, union ibv_gid *gid)
+int _ibv_query_gid(struct ibv_context *context, uint8_t port_num, int index,
+ union ibv_gid *gid)
{
struct verbs_device *verbs_device = verbs_get_device(context->device);
char attr[41];
@@ -240,6 +238,29 @@ LATEST_SYMVER_FUNC(ibv_query_gid, 1_1, "IBVERBS_1.1",
return 0;
}
This should be moved to be near query_sysfs_gid_entry() and given a
better name
Jason
OK, will rename it to be query_sysfs_gid() and will move it to be near
the above which reads the full gid entry information.
In addition, will do the same for _ibv_query_gid_type(), will move to
cmd_device.c and rename it to be query_sysfs_gid_type().
Yishai