Re: [EXT] [PATCH 07/14] RDMA/qedr: Use rdma_umem_for_each_dma_block() instead of open-coding

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Sep 02, 2020 at 03:36:00PM +0000, Michal Kalderon wrote:
> > +		/* If the given pbl is full storing the pbes, move to next pbl.
> > +		 */
> > +		if (pbe_cnt == (pbl_info->pbl_size / sizeof(u64))) {
> > +			pbl_tbl++;
> > +			pbe = (struct regpair *)pbl_tbl->va;
> > +			pbe_cnt = 0;
> >  		}
> >  	}
> >  }
> 
> Thanks,  looks good!

After this series you should try adding ib_umem_find_best_pgsz() to
qedr, it looks pretty simple now..

Jason



[Index of Archives]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Photo]     [Yosemite News]     [Yosemite Photos]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux