On Thu, Jun 11, 2020 at 10:21:49AM +0000, Bernard Metzler wrote: > > >To: "Tom Seewald" <tseewald@xxxxxxxxx> > >From: "Jason Gunthorpe" <jgg@xxxxxxxx> > >Date: 06/10/2020 07:50PM > >Cc: linux-rdma@xxxxxxxxxxxxxxx, "Bernard Metzler" > ><bmt@xxxxxxxxxxxxxx>, "Doug Ledford" <dledford@xxxxxxxxxx> > >Subject: [EXTERNAL] Re: [PATCH next] siw: Fix pointer-to-int-cast > >warning in siw_rx_pbl() > > > >On Wed, Jun 10, 2020 at 12:47:17PM -0500, Tom Seewald wrote: > >> The variable buf_addr is type dma_addr_t, which may not be the same > >size > >> as a pointer. To ensure it is the correct size, cast to a > >uintptr_t. > >> > >> Signed-off-by: Tom Seewald <tseewald@xxxxxxxxx> > >> drivers/infiniband/sw/siw/siw_qp_rx.c | 3 ++- > >> 1 file changed, 2 insertions(+), 1 deletion(-) > >> > >> diff --git a/drivers/infiniband/sw/siw/siw_qp_rx.c > >b/drivers/infiniband/sw/siw/siw_qp_rx.c > >> index 650520244ed0..7271d705f4b0 100644 > >> +++ b/drivers/infiniband/sw/siw/siw_qp_rx.c > >> @@ -139,7 +139,8 @@ static int siw_rx_pbl(struct siw_rx_stream > >*srx, int *pbl_idx, > >> break; > >> > >> bytes = min(bytes, len); > >> - if (siw_rx_kva(srx, (void *)buf_addr, bytes) == bytes) { > >> + if (siw_rx_kva(srx, (void *)(uintptr_t)buf_addr, bytes) == > >> + bytes) { > > > >How is a dma_addr_t being cast to a void *? That can't be right? > >Bernard?? > > > >Jason > > > Hi Tom, Hi Jason, > > Thanks for looking into that. > > siw_rx_kva() calls skb_copy_bits() to move data to its > kernel clients destination. It expects a void * target > address. This is why I chose it for siw_rx_kva() as well. > One could say siw_rx_kva() should better get an uintptr_t > as target argument, which would probably make it look > more clean. And we rename it to siw_rx_kbuf(), and we > cast from uintptr_t to (void *) just for > skb_copy_bits(skb *, off, (void *)dest, len) > > This would avoid all those nasty (void *) casting at all (!) > the places we are calling siw_rx_kva(). But where did the dma_addr_t come from? Jason