On Fri, Dec 13, 2019 at 11:19:16AM +0100, Daniel Vetter wrote: > On Wed, Dec 11, 2019 at 10:57:13PM +0000, Jason Gunthorpe wrote: > > On Thu, Dec 05, 2019 at 11:03:24AM -0500, Jerome Glisse wrote: > > > > > > struct mmu_notifier_mm (ie the mm->mmu_notifier_mm) > > > > -> mmn_mm > > > > struct mm_struct > > > > -> mm > > > > struct mmu_notifier (ie the user subscription to the mm_struct) > > > > -> mn > > > > struct mmu_interval_notifier (the other kind of user subscription) > > > > -> mni > > > > > > What about "interval" the context should already tell people > > > it is related to mmu notifier and thus a notifier. I would > > > just remove the notifier suffix, this would match the below > > > range. > > > > Interval could be a good replacement for mni in the mm/mmu_notififer > > file if we don't do the wholesale rename > > > > > > I think it would be overall nicer with better names for the original > > > > structs. Perhaps: > > > > > > > > mmn_* - MMU notifier prefix > > > > mmn_state <- struct mmu_notifier_mm > > > > mmn_subscription (mmn_sub) <- struct mmu_notifier > > > > mmn_range_subscription (mmn_range_sub) <- struct mmu_interval_notifier > > > > mmn_invalidate_desc <- struct mmu_notifier_range > > > > > > This looks good. > > > > Well, lets just bite the bullet then and switch it. Do you like > > 'state'? I thought that was the weakest one > > Since you're asking, here's my bikeshed. I kinda agree _state looks a bit > strange for this, what about a _link suffix in the spirit of Do you think calling it 'mmn_subscriptions' is clear? Ie a struct mmn_subscriptions holds the lists of struct mmn_subscription and struct mmn_range_subscription? Jason