Re: [PATCH v12 rdma-next 0/8] RDMA/qedr: Use the doorbell overflow recovery mechanism for RDMA

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



> > Please let me know if I messed it up, otherwise I'll apply this in
> > a few days.
>
> Thanks Jason. One small comment is that the length field was removed from siw + efa 
> But not qedr_user_mmap_entry, I can also send a patch after to fix this. 
> And one small insignificant typo below

qedr looked to me like it was using non page size lengths, so I left
it..

> > diff --git a/drivers/infiniband/core/ib_core_uverbs.c
> > b/drivers/infiniband/core/ib_core_uverbs.c
> > index 88d9d47fb8adaa..6238842fd06402 100644
> > +++ b/drivers/infiniband/core/ib_core_uverbs.c
> > @@ -11,14 +11,14 @@
> > 
> >  /**
> > - * rdma_user_mmap_entry_insert() - Insert an entry to the mmap_xa.
> > + * rdma_user_mmap_entry_insert() - Insert an entry to the mmap_xa
> >   *
> >   * @ucontext: associated user context.
> >   * @entry: the entry to insert into the mmap_xa
> >   * @length: length of the address that will be mmapped
> >   *
> >   * This function should be called by drivers that use the rdma_user_mmap
> > - * interface for handling user mmapped addresses. The database is handled
> > in
> > - * the core and helper functions are provided to insert entries into the
> > - * database and extract entries when the user calls mmap with the given
> > key.
> > - * The function allocates a unique key that should be provided to user, the
> > user
> > - * will use the key to retrieve information such as address to
> > - * be mapped and how.
> > + * interface for implementing their mmap syscall A database of mmap
> > + offsets is
> > + * handled in the core and helper functions are provided to insert
> > + entries
> > + * into the database and extract entries when the user calls mmap with
> > + the
> > + * given offset.  The function allocates a unique page offset that
> > + should be
> > + * provided to user, the user will use the iffset to retrieve
> 
> Typo - should be offset

Thanks, I'll fix that

Jason



[Index of Archives]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Photo]     [Yosemite News]     [Yosemite Photos]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux