On Wed, Feb 27, 2019 at 10:57:16AM +0200, Gal Pressman wrote: > On 27-Feb-19 10:36, Leon Romanovsky wrote: > > On Wed, Feb 27, 2019 at 10:31:29AM +0200, Gal Pressman wrote: > >> On 26-Feb-19 21:32, Leon Romanovsky wrote: > >>> On Thu, Feb 21, 2019 at 05:33:10PM +0200, Gal Pressman wrote: > >>>> Add the EFA common commands implementation. > >>>> > >>>> Signed-off-by: Gal Pressman <galpress@xxxxxxxxxx> > > > > <...> > > > >>>> + err = efa_com_cmd_exec(aq, > >>>> + (struct efa_admin_aq_entry *)&create_qp_cmd, > >>>> + sizeof(create_qp_cmd), > >>>> + (struct efa_admin_acq_entry *)&cmd_completion, > >>>> + sizeof(cmd_completion)); > >>>> + if (unlikely(err)) { > >>> > >>> There is no need to add likely/unlikely not in data path. > >> > >> Doesn't hurt though, right? > > > > Right, if readability is not important, it won't hurt. > > Actually, I find likely/unlikely easier to read as it helps you identify the > main flows. > In this case the main flow is clear, but I wouldn't say that it hurts readability. The general guidance in the kernel is to follow the 'success oriented flow', so if you are looking at an 'if (thing) {goto exit/return}' it really should be a failure path. Jason