> -----Original Message----- > From: Jason Gunthorpe > Sent: Monday, January 14, 2019 2:07 PM > To: Parav Pandit <parav@xxxxxxxxxxxx> > Cc: Leon Romanovsky <leon@xxxxxxxxxx>; Doug Ledford > <dledford@xxxxxxxxxx>; Leon Romanovsky <leonro@xxxxxxxxxxxx>; RDMA > mailing list <linux-rdma@xxxxxxxxxxxxxxx> > Subject: Re: [PATCH rdma-next 1/7] RDMA: Rename port_callback to > port_init > > On Sun, Jan 13, 2019 at 02:14:16PM -0700, Parav Pandit wrote: > > > > - ret = ib_device_register_sysfs(device, port_callback); > > > + ret = ib_device_register_sysfs(device); > > > if (ret) { > > > dev_warn(&device->dev, > > > "Couldn't register device with driver model\n"); diff - > > > > Below hunk is missing. I guess it happened during rebase time when > > Kamals ops series got merged first. > > Yes, this isn't the first time :( > > > diff --git a/drivers/infiniband/core/device.c > > b/drivers/infiniband/core/device.c > > index 4c5c372..5aed07c 100644 > > +++ b/drivers/infiniband/core/device.c > > @@ -1379,6 +1379,7 @@ void ib_set_device_ops(struct ib_device *dev, > const struct ib_device_ops *ops) > > SET_DEVICE_OP(dev_ops, set_vf_guid); > > SET_DEVICE_OP(dev_ops, set_vf_link_state); > > SET_DEVICE_OP(dev_ops, unmap_fmr); > > + SET_DEVICE_OP(dev_ops, init_port); > > } > > > > It should be, after renaming it. > > + SET_DEVICE_OP(dev_ops, port_init); > > I did the rename you asked for as well, please check I checked the merged patch in wip/jgg-for-next branch. It looks good now. Thanks.