On Wed, Dec 05, 2018 at 10:57:16AM +0200, Gal Pressman wrote: > On 04-Dec-18 18:03, Jason Gunthorpe wrote: > > On Tue, Dec 04, 2018 at 02:04:25PM +0200, Gal Pressman wrote: > > > >> +int efa_com_get_device_attr(struct efa_com_dev *edev, > >> + struct efa_com_get_device_attr_result *result) > >> +{ > >> + struct pci_dev *pdev = container_of(edev->dmadev, struct pci_dev, dev); > >> + struct efa_admin_get_feature_resp resp; > >> + int err; > >> + > >> + err = efa_com_get_feature(edev, &resp, EFA_ADMIN_DEVICE_ATTR); > >> + if (unlikely(err)) { > >> + pr_err("Failed to get network attributes %d\n", err); > >> + return err; > >> + } > >> + > >> + result->fw_version = resp.u.device_attr.fw_version; > >> + result->admin_api_version = resp.u.device_attr.admin_api_version; > >> + result->vendor_id = pdev->vendor; > >> + result->vendor_part_id = pdev->device; > >> + result->device_version = resp.u.device_attr.device_version; > >> + result->supported_features = resp.u.device_attr.supported_features; > >> + result->phys_addr_width = resp.u.device_attr.phys_addr_width; > >> + result->virt_addr_width = resp.u.device_attr.virt_addr_width; > >> + result->db_bar = resp.u.device_attr.db_bar; > > > > Don't randomly intermix horizontal whitespace with normal whitepace, > > scrub everything for this.. > > > > Jason > > > > Guess it's a personal taste thing, but I find this more readable. Is this a real > issue? Yes, I'll tolerate it for structs, enums and defines, which is the usual kernel style but not in functions. This style creates a maintenance nightmare. Jason