Re: [PATCH 4/9] RDMA/uverbs: Simplify method definition macros

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Jun 27, 2018 at 05:24:52AM -0600, Guy Levi(SW) wrote:
> > diff --git a/include/rdma/uverbs_named_ioctl.h b/include/rdma/uverbs_named_ioctl.h
> > index 228421f2a427b6..06eac48ec4f233 100644
> > +++ b/include/rdma/uverbs_named_ioctl.h
> > @@ -45,14 +45,32 @@
> >  #define UVERBS_HANDLER(id)	_UVERBS_NAME(UVERBS_MODULE_NAME, _handler_##id)
> >  #define UVERBS_OBJECT(id)	_UVERBS_NAME(UVERBS_MOUDLE_NAME, _object_##id)
> > 
> > -#define DECLARE_UVERBS_NAMED_METHOD(id, ...)	\
> > -	DECLARE_UVERBS_METHOD(UVERBS_METHOD(id), id, UVERBS_HANDLER(id), ##__VA_ARGS__)
> > +#define UVERBS_METHOD_ATTRS(id)                                                \
> > +	_UVERBS_NAME(UVERBS_MODULE_NAME, _method_attrs_##id)
> > 
> > -#define DECLARE_UVERBS_NAMED_METHOD_WITH_HANDLER(id, handler, ...)	\
> > -	DECLARE_UVERBS_METHOD(UVERBS_METHOD(id), id, handler, ##__VA_ARGS__)
> > +#define DECLARE_UVERBS_NAMED_METHOD(_method_id, ...)                           \
> 
> Why do you insist to specify in macro's names the term 'NAMED' (same
> for the header file name)?  There is another usage which is
> un-NAMED?
 
It is a bit confusing but 'named' is supposed to refer to the use of
UVERBS_MOUDLE_NAME - I think.

Another series is needed to clean this and remove this entire
confusing mechanism. I am just keeping it as it is for now to avoid
getting a series that is too big.

Jason
--
To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Photo]     [Yosemite News]     [Yosemite Photos]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux