Hi Doug and Jason, Here are some general code cleanups and improvements to target the next release. Nothing too scary here. Changes are limited to hfi1 and one to rdmavt. --- Kaike Wan (2): IB/hfi1: Remove unused variable IB/hfi1: Rename exp_lock to exp_mutex Mike Marciniszyn (5): IB/hfi1: Add bypass register defines and replace blind constants IB/hfi1: Move normal functions from hfi1_devdata to const array IB/hfi1: Move rhf_offset from devdata to ctxtdata IB/hfi1: Remove rcvhdrsize IB/rdmavt, IB/hfi1: Create device dependent s_flags drivers/infiniband/hw/hfi1/chip.c | 11 +---- drivers/infiniband/hw/hfi1/chip_registers.h | 6 +++ drivers/infiniband/hw/hfi1/driver.c | 63 +++++++++++++++------------ drivers/infiniband/hw/hfi1/hfi.h | 29 ++++-------- drivers/infiniband/hw/hfi1/init.c | 29 +++--------- drivers/infiniband/hw/hfi1/pio.c | 6 +-- drivers/infiniband/hw/hfi1/qp.c | 6 +-- drivers/infiniband/hw/hfi1/qp.h | 24 +++++++++- drivers/infiniband/hw/hfi1/rc.c | 6 +-- drivers/infiniband/hw/hfi1/ruc.c | 14 +++--- drivers/infiniband/hw/hfi1/user_exp_rcv.c | 10 ++-- drivers/infiniband/hw/hfi1/user_sdma.h | 4 -- drivers/infiniband/hw/hfi1/verbs.c | 4 +- include/rdma/rdmavt_qp.h | 30 +++++++------ 14 files changed, 125 insertions(+), 117 deletions(-) -- -Denny -- To unsubscribe from this list: send the line "unsubscribe linux-rdma" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html