On Mon, Jan 15, 2018 at 06:48:06PM +0200, Yishai Hadas wrote: > > IBV_INIT_CMD_RESP(cmd, cmd_size, ALLOC_PD, resp, resp_size); > >@@ -338,7 +338,7 @@ int ibv_cmd_open_xrcd(struct ibv_context *context, struct verbs_xrcd *xrcd, > > int vxrcd_size, > > struct ibv_xrcd_init_attr *attr, > > struct ibv_open_xrcd *cmd, size_t cmd_size, > >- struct ibv_open_xrcd_resp *resp, size_t resp_size) > >+ struct ib_uverbs_close_xrcd *resp, size_t resp_size) > > This had to be ib_uverbs_open_xrcd_resp, correct ? need to fix in the > drivers' code that uses this as well. For clarity, yes. I will fix it.. I manually caught many others like this but missed this one The two structs are identical, which is why they got conflated together, so it doesn't create a bug - just confusion: struct ib_uverbs_open_xrcd_resp { __u32 xrcd_handle; }; struct ib_uverbs_close_xrcd { __u32 xrcd_handle; }; -- To unsubscribe from this list: send the line "unsubscribe linux-rdma" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html