> > What's the feature associated with MLX5_WQ_END_PAD_MODE_ALIGN? > > It seems it was there before this patch series and bears a similar name. > > Right, this series exposes this already existing feature to the user. I'm under the impression that they are somewhat different (per QP type??) from this code: + if (init_attr->create_flags & IB_QP_CREATE_SCATTER_END_PADDING) { + if (!MLX5_CAP_GEN(dev->mdev, end_pad)) { + mlx5_ib_dbg(dev, "scatter end padding is not supported\n"); + err = -EOPNOTSUPP; + goto err; + } else if (init_attr->qp_type != IB_QPT_RAW_PACKET) { + MLX5_SET(qpc, qpc, end_padding_mode, + MLX5_WQ_END_PAD_MODE_ALIGN); + } else { + qp->flags |= MLX5_IB_QP_SCATTER_END_PADDING; + } + } + But if indeed they are the same then please consider using the same names to increase readability. Thanks, Ram ��.n��������+%������w��{.n�����{���fk��ܨ}���Ơz�j:+v�����w����ޙ��&�)ߡ�a����z�ޗ���ݢj��w�f