On 18/04/17 03:03 PM, Jason Gunthorpe wrote: > What about something more incremental like this instead: > - dma_ops will set map_sg_p2p == map_sg when they are updated to > support p2p, otherwise DMA on P2P pages will fail for those ops. > - When all ops support p2p we remove the if and ops->map_sg then > just call map_sg_p2p > - For now the scatterlist maintains a bit when pages are added indicating if > p2p memory might be present in the list. > - Unmap for p2p and non-p2p is the same, the underlying ops driver has > to make it work. > > diff --git a/include/linux/dma-mapping.h b/include/linux/dma-mapping.h > index 0977317c6835c2..505ed7d502053d 100644 > --- a/include/linux/dma-mapping.h > +++ b/include/linux/dma-mapping.h > @@ -103,6 +103,9 @@ struct dma_map_ops { > int (*map_sg)(struct device *dev, struct scatterlist *sg, > int nents, enum dma_data_direction dir, > unsigned long attrs); > + int (*map_sg_p2p)(struct device *dev, struct scatterlist *sg, > + int nents, enum dma_data_direction dir, > + unsigned long attrs); > void (*unmap_sg)(struct device *dev, > struct scatterlist *sg, int nents, > enum dma_data_direction dir, > @@ -244,7 +247,15 @@ static inline int dma_map_sg_attrs(struct device *dev, struct scatterlist *sg, > for_each_sg(sg, s, nents, i) > kmemcheck_mark_initialized(sg_virt(s), s->length); > BUG_ON(!valid_dma_direction(dir)); > - ents = ops->map_sg(dev, sg, nents, dir, attrs); > + > + if (sg_has_p2p(sg)) { > + if (ops->map_sg_p2p) > + ents = ops->map_sg_p2p(dev, sg, nents, dir, attrs); > + else > + return 0; > + } else > + ents = ops->map_sg(dev, sg, nents, dir, attrs); > + > BUG_ON(ents < 0); > debug_dma_map_sg(dev, sg, nents, ents, dir); I could get behind this. Though a couple of points: 1) It means that sg_has_p2p has to walk the entire sg and check every page. Then map_sg_p2p/map_sg has to walk it again and repeat the check then do some operation per page. If anyone is concerned about the dma_map performance this could be an issue. 2) Without knowing exactly what the arch specific code may need to do it's hard to say that this is exactly the right approach. If every dma_ops provider has to do exactly this on every page it may lead to a lot of duplicate code: foreach_sg page: if (pci_page_is_p2p(page)) { dma_addr = pci_p2p_map_page(page) if (!dma_addr) return 0; continue } ... The only thing I'm presently aware of is the segment check and applying the offset to the physical address -- neither of which has much to do with the specific dma_ops providers. It _may_ be that this needs to be bus specific and not arch specific which I think is what Dan may be getting at. So it may make sense to just have a pci_map_sg_p2p() which takes a dma_ops struct it would use for any page that isn't a p2p page. Logan -- To unsubscribe from this list: send the line "unsubscribe linux-rdma" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html