RE: [PATCH RFC 2/2] RDMA/isert: Support iWARP transport

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




> -----Original Message-----
> From: Jason Gunthorpe [mailto:jgunthorpe@xxxxxxxxxxxxxxxxxxxx]
> Sent: Thursday, June 25, 2015 1:25 PM
> To: Steve Wise
> Cc: linux-rdma@xxxxxxxxxxxxxxx; sagig@xxxxxxxxxxxx; orgerlitz@xxxxxxxxxxxx; raid@xxxxxxxxxxxx
> Subject: Re: [PATCH RFC 2/2] RDMA/isert: Support iWARP transport
> 
> On Thu, Jun 25, 2015 at 10:39:23AM -0500, Steve Wise wrote:
> > +	/*
> > +	 * IWARP transports need REMOTE_WRITE for MRs used as the target of
> > +	 * an RDMA_READ.  Since the DMA MR is used for all ports, then if
> > +	 * any port is running IWARP, add REMOTE_WRITE.
> > +	 */
> > +	if (any_port_is_iwarp(device))
> 
> It would be nice to have a new-style cap test for this instead of open
> coding iwarp. Similar to rdma_cap_read_multi_sge
> 

That would be ok with me.  Now for naming this new function:

rdma_cap_read_requires_remote_write_rights()

That's pretty long.  Any other ideas for naming this?


> I'm confused about the 'any_port_is_iwarp' stuff too, I thought if one
> port was iwarp then all ports had to be iwarp?
> 

Currently no device supports iwarp + any other protocol.

> Even if we move away from that, I would think that some caps must be
> the same on all ports, and multi_sge, remote_write, etc would fit into
> that limitation.
> 

I'm happy with making this a device-global capability.  If it becomes a per-port capability, then the code can change later. 

Steve.

--
To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Photo]     [Yosemite News]     [Yosemite Photos]     [Linux Kernel]     [Linux SCSI]     [XFree86]
  Powered by Linux