On Fri, Sep 06, 2024 at 05:34:44PM +0800, Junxian Huang wrote: > From: Feng Fang <fangfeng4@xxxxxxxxxx> > > DIP algorithm requires a one-to-one mapping between dgid and dip_idx. > Currently a queue 'spare_idx' is used to store QPN of QPs that use > DIP algorithm. For a new dgid, use a QPN from spare_idx as dip_idx. > This method lacks a mechanism for deduplicating QPN, which may result > in different dgids sharing the same dip_idx and break the one-to-one > mapping requirement. > > This patch replaces spare_idx with two new bitmaps: qpn_bitmap to record > QPN that is not being used as dip_idx, and dip_idx_map to record QPN > that is being used. Besides, introduce a reference count of a dip_idx > to indicate the number of QPs that using this dip_idx. When creating > a DIP QP, if it has a new dgid, set the corresponding bit in dip_idx_map, > otherwise add 1 to the reference count of the reused dip_idx and set bit > in qpn_bitmap. When destroying a DIP QP, decrement the reference count > by 1. If it becomes 0, set bit in qpn_bitmap and clear bit in dip_idx_map. > > Fixes: eb653eda1e91 ("RDMA/hns: Bugfix for incorrect association between dip_idx and dgid") > Fixes: f91696f2f053 ("RDMA/hns: Support congestion control type selection according to the FW") > Signed-off-by: Feng Fang <fangfeng4@xxxxxxxxxx> > Signed-off-by: Junxian Huang <huangjunxian6@xxxxxxxxxxxxx> > --- > drivers/infiniband/hw/hns/hns_roce_device.h | 6 +-- > drivers/infiniband/hw/hns/hns_roce_hw_v2.c | 58 ++++++++++++++++++--- > drivers/infiniband/hw/hns/hns_roce_hw_v2.h | 1 + > drivers/infiniband/hw/hns/hns_roce_qp.c | 16 ++++-- > 4 files changed, 67 insertions(+), 14 deletions(-) It is strange implementation, double bitmap and refcount looks like open-coding of some basic coding patterns. Let's wait with applying it for now. Thanks