On 8/27/24 4:22 AM, Shen Lichuan wrote: > Use the max() macro to simplify the function and improve > its readability. > > Signed-off-by: Shen Lichuan <shenlichuan@xxxxxxxx> > --- > drivers/infiniband/hw/qib/qib_iba7220.c | 2 +- > drivers/infiniband/hw/qib/qib_iba7322.c | 2 +- > 2 files changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/infiniband/hw/qib/qib_iba7220.c b/drivers/infiniband/hw/qib/qib_iba7220.c > index 78dfe98ebcf7..4c96b66a93b5 100644 > --- a/drivers/infiniband/hw/qib/qib_iba7220.c > +++ b/drivers/infiniband/hw/qib/qib_iba7220.c > @@ -4094,7 +4094,7 @@ static int qib_init_7220_variables(struct qib_devdata *dd) > updthresh = 8U; /* update threshold */ > if (dd->flags & QIB_HAS_SEND_DMA) { > dd->cspec->sdmabufcnt = dd->piobcnt4k; > - sbufs = updthresh > 3 ? updthresh : 3; > + sbufs = max(updthresh, 3); > } else { > dd->cspec->sdmabufcnt = 0; > sbufs = dd->piobcnt4k; > diff --git a/drivers/infiniband/hw/qib/qib_iba7322.c b/drivers/infiniband/hw/qib/qib_iba7322.c > index 9db29916e35a..5a059ec08780 100644 > --- a/drivers/infiniband/hw/qib/qib_iba7322.c > +++ b/drivers/infiniband/hw/qib/qib_iba7322.c > @@ -6633,7 +6633,7 @@ static int qib_init_7322_variables(struct qib_devdata *dd) > */ > if (dd->flags & QIB_HAS_SEND_DMA) { > dd->cspec->sdmabufcnt = dd->piobcnt4k; > - sbufs = updthresh > 3 ? updthresh : 3; > + sbufs = max(updthresh, 3); > } else { > dd->cspec->sdmabufcnt = 0; > sbufs = dd->piobcnt4k; I don't see how this improves readability or makes the function simpler. I'm not opposed to it, just don't see it as an improvement. -Denny