Recently added mlx5_cpumask_default_spread() makes for_each_numa_hop_mask() opencoding cpumask_local_spread(). This series replaces mlx5_cpumask_default_spread() with generic cpumask_local_spread(). And because mlx5_cpumask_default_spread() is the only user of for_each_numa_hop_mask() machinery, drops it entirely. Regarding for_each_numa_hop_mask(), I've got a small series introducing a better version of it - for_each_numa_cpu(): https://lore.kernel.org/netdev/20230430171809.124686-1-yury.norov@xxxxxxxxx/T/ But with the lack of interest, I believe it's wotrth to drop for_each_numa_hop_mask() and put for_each_numa_cpu() on hold until further updates... Yury Norov (4): net: mellanox: drop mlx5_cpumask_default_spread() Revert "sched/topology: Introduce for_each_numa_hop_mask()" Revert "sched/topology: Introduce sched_numa_hop_mask()" lib/cpumask: don't mention for_each_numa_hop_mask in cpumask_local_spread()" drivers/net/ethernet/mellanox/mlx5/core/eq.c | 28 ++--------------- include/linux/topology.h | 25 --------------- kernel/sched/topology.c | 33 -------------------- lib/cpumask.c | 21 ------------- 4 files changed, 2 insertions(+), 105 deletions(-) -- 2.39.2