On 4/7/2023 1:59 PM, Haiyang Zhang wrote: > Update RX data path to allocate and use RX queue DMA buffers with > proper size based on potentially various MTU sizes. > > Signed-off-by: Haiyang Zhang <haiyangz@xxxxxxxxxxxxx> > > --- > V2: > Refectored to multiple patches for readability. Suggested by Yunsheng Lin. Reviewed-by: Jesse Brandeburg <jesse.brandeburg@xxxxxxxxx> One tiny nit below, but not worth a respin. > @@ -1764,6 +1798,7 @@ static struct mana_rxq *mana_create_rxq(struct mana_port_context *apc, > struct mana_obj_spec wq_spec; > struct mana_obj_spec cq_spec; > struct gdma_queue_spec spec; > + unsigned int mtu = ndev->mtu; This one isn't quite RCT order. I'd only change it if you have another respin for some reason. Ha, I see you remove that line in the next patch, never mind...