On 4/17/21 12:16 AM, Christophe JAILLET wrote: > 'kasprintf()' can replace a kmalloc/strcpy/strcat sequence. > It is less verbose and avoid the use of a magic number (64). > > Anyway, the underlying 'alloc_workqueue()' would only keep the 24 first > chars (i.e. sizeof(struct workqueue_struct->name) = WQ_NAME_LEN). > > Signed-off-by: Christophe JAILLET <christophe.jaillet@xxxxxxxxxx> > --- > drivers/net/ethernet/mellanox/mlx5/core/health.c | 4 +--- > 1 file changed, 1 insertion(+), 3 deletions(-) > > diff --git a/drivers/net/ethernet/mellanox/mlx5/core/health.c b/drivers/net/ethernet/mellanox/mlx5/core/health.c > index 9ff163c5bcde..a5383e701b4b 100644 > --- a/drivers/net/ethernet/mellanox/mlx5/core/health.c > +++ b/drivers/net/ethernet/mellanox/mlx5/core/health.c > @@ -802,12 +802,10 @@ int mlx5_health_init(struct mlx5_core_dev *dev) > mlx5_fw_reporters_create(dev); > > health = &dev->priv.health; > - name = kmalloc(64, GFP_KERNEL); > + name = kasprintf(GFP_KERNEL, "mlx5_health%s", dev_name(dev->device)); > if (!name) > goto out_err; > > - strcpy(name, "mlx5_health"); > - strcat(name, dev_name(dev->device)); > health->wq = create_singlethread_workqueue(name); > kfree(name); > if (!health->wq) Instead of modifying the mlx5 driver, please change the definition of the create_singlethread_workqueue() such that it accept a format specifier and a variable number of arguments. Thanks, Bart.