Re: Configuring pppd to accept link-local IPv6 interface id from remote peer

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Looking at the git master branch, it looks like Pali Rohár is actively
working in this space:
Well, I'll give a look to find what's wrong.

Just a quick follow up to say that it is all working fine after I upgraded to version 2.4.9 of pppd.

I had initially been using version 2.4.7, that came with Raspberry Pi OS (buster).
I had also been testing using git master of the ppp repo on the 'client'.

But I hadn't tried upgrading the 'server' (the peer configured with the interface identifiers). After upgrading to 2.4.9 on the 'server' it works perfectly - even with an older version of pppd on the 'client'. I haven't tracked down the commit that fixed it but I guess it was something to do with failing to Nack the random interface identifier sent by the peer.

Thank you for your help and thoughts on the issue.


|pppd file ./ppp-options ipv6cp-accept-local /dev/ttyAMA0 115200 using channel 368 Using interface ppp0 Connect: ppp0 <--> /dev/ttyAMA0 sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x7f793cbe>] rcvd [LCP ConfReq id=0xb <asyncmap 0x0> <magic 0xecde7250>] sent [LCP ConfAck id=0xb <asyncmap 0x0> <magic 0xecde7250>] rcvd [LCP ConfReq id=0xb <asyncmap 0x0> <magic 0xecde7250>] sent [LCP ConfAck id=0xb <asyncmap 0x0> <magic 0xecde7250>] rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x7f793cbe>] sent [LCP EchoReq id=0x0 magic=0x7f793cbe] sent [IPV6CP ConfReq id=0x1 <addr fe80::0dfd:3c3b:e130:91ce>] rcvd [LCP EchoReq id=0x0 magic=0xecde7250] sent [LCP EchoRep id=0x0 magic=0x7f793cbe] rcvd [LCP EchoRep id=0x0 magic=0xecde7250] rcvd [IPV6CP ConfReq id=0xb <addr fe80::0000:0000:0000:0001>] sent [IPV6CP ConfAck id=0xb <addr fe80::0000:0000:0000:0001>] rcvd [IPV6CP ConfNak id=0x1 <addr fe80::0000:0000:0000:0002>] sent [IPV6CP ConfReq id=0x2 <addr fe80::0000:0000:0000:0002>] rcvd [IPV6CP ConfAck id=0x2 <addr fe80::0000:0000:0000:0002>] local LL address fe80::0000:0000:0000:0002 remote LL address fe80::0000:0000:0000:0001 Script /etc/ppp/ipv6-up started (pid 7049) Script /etc/ppp/ipv6-up finished (pid 7049), status = 0x0 |

[Index of Archives]     [Linux Audio Users]     [Linux for Hams]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Video 4 Linux]     [Fedora Users]

  Powered by Linux