Re: PPPOE on Arm

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Am 05.05.2019 19:57, schrieb Marco d'Itri:
> On May 05, walter harms <wharms@xxxxxx> wrote:
>> I was using PPPOE on a raspi and it terminated with "invalid value",
> Which raspi model and which distribution, exactly?
raspi3 with raspian (it was for testing, only)
I tried also different kernels but no success.

>> while the same setup on x86_64 worked fine.
> Is your pppd configuration unusual in any way?
not really, but i need a VLAN (eth0.7)

this is the line i used for testing, it includes everything.

/usr/bin/setsid /usr/sbin/pppd pty '/usr/sbin/pppoe -p /var/run/ -I eth0.7 -T 80 -U  -m 1412' noipdefault noauth
default-asyncmap defaultroute hide-password nodetach mtu 1492 mru 1492 noaccomp nodeflate nopcomp novj novjccomp user xxxxx lcp-echo-interval 20
lcp-echo-failure 3

>> is anyone working with PPPOE ?
> I use pppd and the PPPoE plugin from Debian 9 on a 32 bit armv7l system 
> (i.e. armhf) and it works fine.

[Index of Archives]     [Linux Audio Users]     [Linux for Hams]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Video 4 Linux]     [Fedora Users]

  Powered by Linux