> > -static cpumask_var_t c1e_mask; > > +static cpumask_var_t amd_e400_mask; > > Actually, the correct name should be IMHO > > amd_e400_c1e_mask okay. > > - c1e_detected = true; > > + amd_e400_detected = true; > > Hmm, c1e_detected is still the correct name since those two bits in > the INT_PENDING MSR mean simply that the system can either generate an > IO read or an SMI to enter C1E irrespective of E400. So I'd leave it > c1e_detected. We don't run the code that sets this flag unless cpu_has_amd_erratum(amd_erratum_400) so how about this?: - c1e_detected + amd_e400_c1e_detected > > -void __init init_c1e_mask(void) > > +void __init init_amd_e400_mask(void) > > Same here, init_amd_e400_c1e_mask. done. thanks, Len Brown, Intel Open Source Technology Center _______________________________________________ linux-pm mailing list linux-pm@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linux-foundation.org/mailman/listinfo/linux-pm