On Tue, Jul 21, 2009 at 11:50:29AM +0100, Alan Jenkins wrote: > +struct block_device *bdcopy(struct block_device *bdev) > +{ > + atomic_inc(&bdev->bd_inode->i_count); > + return bdev; > +} > + > +EXPORT_SYMBOL(bdcopy); The function name doesn't make any sense. You don't copy anything here, but you grab a reference to it. A better name would be bdgrab, mirroing the names of functions like igrab. A kerneldoc comment documenting it would also be very helpful. Why do you export it? The swapfile code is not actually modular. _______________________________________________ linux-pm mailing list linux-pm@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linux-foundation.org/mailman/listinfo/linux-pm