Michael Trimarchi wrote: > > diff --git a/drivers/base/power/main.c b/drivers/base/power/main.c > index 69b4ddb..baae309 100644 > --- a/drivers/base/power/main.c > +++ b/drivers/base/power/main.c > @@ -65,6 +65,45 @@ void device_pm_unlock(void) > } > > /** > + * device_set_no_suspend_enable - Mark the device as used by userspace > + * application > + */ > +void device_set_no_suspend_enable(struct device *dev, bool enable) > +{ Small nit: "/**" means "this is kernel-doc notation", but the kernel-doc notation is not correct, so please either (a) make it correct (preferred) or (b) don't use "/**" there. For (a), it should look more like: /** * device_set_no_suspend_enable - mark the device as used by userspace application * @dev: the target device * @enable: true if the device should be marked as "no_suspend" Please correct these as needed, especially the @enable flag. It seems a bit like a double negative, unfortunately. Thanks. -- ~Randy _______________________________________________ linux-pm mailing list linux-pm@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linux-foundation.org/mailman/listinfo/linux-pm