On Tue, 2008-05-27 at 18:15 -0400, Vivek Goyal wrote: [...] > > But, because IOAPIC may need to be in original state during > > suspend/resume, so it is not appropriate to call disable_IO_APIC() in > > ioapic_suspend(). So I think we can call disable_IO_APIC() in new > > hibernation/restore callback. > > My hunch is suspend/resume will still work if we put this call in > ioapic_suspend() but I would not recommend that. suspend/resume does > not need to put IOAPIC in legacy mode. > > I am not sure what is "new hibernation/restore callback"? Are you > referring to new patches from Rafel? Yes. Rafel has a new patch to separate suspend and hibernation device call backs. http://kerneltrap.org/Linux/Separating_Suspend_and_Hibernation > I think this issue is specifc to kexec and kjump so probably we should > not tweaking any suspend/resume related bit. > > How about calling disable_IO_APIC() in kexec_jump()? We can probably even > optimize it by calling it only when we are transitioning into new image > for the first time and not for subsquent transitions (by keeping some kind of > count in kimage). This is little hackish but, should work... Yes. This issue is kexec/kjump specific. We can call it in kexec_jump(). Maybe we also need call something other in native_machine_shutdown()? BTW: I have a new version -v10: http://lkml.org/lkml/2008/5/22/106, do you have time to review it? Best Regards, Huang Ying _______________________________________________ linux-pm mailing list linux-pm@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linux-foundation.org/mailman/listinfo/linux-pm